Хакатон/Исполнитель Черепашка

Материал из Letopisi.Ru — «Время вернуться домой»
Перейти к: навигация, поиск

ScratchCat-Small.png

Исполнитель Черепашка
Автор(ы) разработки Зорина Е. М.
Возраст участников до 14 лет
Количество участников ограничено количеством компьютеров
Необходимое оборудование компьютер на каждого, доступ в сеть, браузер, возможно Scratch 2.0 предустановленный
Необходимое команды Движение - потому что Черепашка будет перемещаться по экрану, Перо - потому что Черепашка будут менять костюмы, События - самые первые команды скрипта, Управление - цикл, повторение действий Черепашки
Студии, материалы которых будут использоваться https://scratch.mit.edu/studios/1928576/
Задачи на программирование рисование по заданным командам, поворот и повторение
Задачи на взаимодействие найти партнеров и организовать команду, создать студию, распределить задачи между участниками проекта

У исполнителя Черепашки всего четыре команды:

Вперед N – движение вперед на N шагов,

Направо M – поворот по часовой стрелке на M градусов;

Налево M – поворот против часовой стрелки на M градусов

Повторить K [Команда1, Команда2…] – повторить алгоритм K раз.

Как команды исполнителя Черепашка соответствуют командам Скретча:


Scratch Черепашка
  повторить (10)
    
Повторить K [Команда1, Команда2…]
  идти (10) шагов
    
Вперед N
  повернуть @turnRight на (15) градусов
    
Направо M
  повернуть @turnLeft на(15) градусов
    
Налево M

Содержание

Пример рисунка

Scratch Черепашка
  Когда щелкнут по @greenFlag
   очистить
   опустить перо
   повторить (12)
     повторить (4)
      идти (50) шагов
      повернуть @turnLeft на(90) градусов 
     конец
    повернуть @turnRight на(12) градусов
  конец 
    
Повтори 12

[Повтори 4

[Вперед 50

Налево 90]

Направо 12]


Если после того, как рисунок нарисован, кот мешает вам ответить на вопрос, просто оттащите его мышкой на свободное пространство на сцене.

Выполнив задание, выберите букву, написанную напротив правильного ответа и в итоге должно получиться кодовое слово.

Задание 1

Повтори 7 [Вперед 100 Направо 60 Вперед 20]

Какая фигура появится на экране?

1) незамкнутая ломаная линия; Р

2) правильный треугольник; К

3) правильный 7-угольник; П

4) правильный 6-угольник. Ц

Задание 2

Повтори 14 [Направо 120 Вперед 50 Налево 90]

Какая фигура появится на экране?

1) незамкнутая ломаная линия; О

2) квадрат; Е

3) правильный 12-угольник; А

4) равносторонний треугольник. И

Задание 3

Повтори 9 [Вперед 15 Направо 70]

Какая фигура появится на экране?

1) незамкнутая ломаная линия; К

2) правильный 24-угольник; П

3) правильный 9-угольник; Н

4) правильный 5-угольник. Р

Задание 4

Повтори 12 [Повтори 4 [Вперед 50 Налево 90] Налево 30]

Из каких фигур состоит рисунок?

1) квадрат; А

2) круг; О

3) треугольник; И

4) ромб. Е

Задание 5

Повтори 12 [Вперед 100 Налево 150]

Какая фигура появится на экране?

1) незамкнутая ломаная линия; Р

2) квадрат; В

3) 12-лучевая звезда; П

4) правильный 7-угольник С

Задание 6

Повтори 7 [Вперед 70 Направо 120]

Какая фигура появится на экране?

1) правильный шестиугольник И

2) незамкнутая ломаная линия Р

3) правильный семиугольник О

4) правильный треугольник К

Задание 7

Повтори 8 [Повтори 4 [Вперед 10 Налево 90] Вперед 60 Налево 45]

Сколько маленьких квадратов содержит фигура?

1) четыре; Р

2) восемь; А

3) десять; П

4) двенадцать О

Идеи

Основываясь на полученных знаниях по рисованию с помощью Черепашки, создайте:

1. Смайлик

2. Цветок или букет

3. Красивый узор

4. Спиннер

5. Танграм

Персональные инструменты
Инструменты
Акция ВЫХОДИ В ИНТЕРНЕТ 2015

организаторы проекта
PH International
www.Iteach.ru
Корпорация Intel
Компания ТрансТелеКом